summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2050e57a6..5e234eedf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,7 +202,11 @@ if(WIN32)
# install(FILES bin/minetestserver.exe DESTINATION bin)
#endif()
- set(CPACK_PACKAGE_FILE_NAME "${PROJECT_NAME}-${VERSION_STRING}-win32")
+ if(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ set(CPACK_PACKAGE_FILE_NAME "${PROJECT_NAME}-${VERSION_STRING}-win64")
+ else(CMAKE_SIZEOF_VOID_P EQUAL 8)
+ set(CPACK_PACKAGE_FILE_NAME "${PROJECT_NAME}-${VERSION_STRING}-win32")
+ endif(CMAKE_SIZEOF_VOID_P EQUAL 8)
set(CPACK_GENERATOR ZIP)