summaryrefslogtreecommitdiff
path: root/src/json/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/json/CMakeLists.txt')
-rw-r--r--src/json/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/json/CMakeLists.txt b/src/json/CMakeLists.txt
new file mode 100644
index 000000000..0957799aa
--- /dev/null
+++ b/src/json/CMakeLists.txt
@@ -0,0 +1,14 @@
+if( UNIX )
+ set(json_SRCS jsoncpp.cpp)
+ set(json_platform_LIBS "")
+else( UNIX )
+ set(json_SRCS jsoncpp.cpp)
+ set(json_platform_LIBS "")
+endif( UNIX )
+
+add_library(json ${json_SRCS})
+
+target_link_libraries(
+ json
+ ${json_platform_LIBS}
+)